UCS: FSM: Unable to find Storage Controller Device for sys/chassis-4/blade-2/board/storage-SAS-1 to perform Image update

30 Jan

Here is a strange error that popped up recently.
After server reboot the blade got stuck on 47% of associating service profile.
Here is the error:

Remote Result: Service Unavailable
Remote Error Code: 4106
Remote Error Description: Unable to find Storage Controller Device for sys/chassis-4/blade-2/storage-SAS-1 to perform Image update



When looking in the KVM Console for the blade I can see that it was sitting in the screen below:

Here are the things that I’ve tried to fix this and none of these worked:
1. As it was saying about the image update for Storage adapter I though I’ll remove Host firmware policy from the service profile.
2. Next I created a new Host firmware policy but only added firmware SAS storage controller and chose different version than it had.
3. Remove and add service profile back

Here is what worked though:
Removed service profile from blade, re-acknowledged the blade added service profile back. After this the error was gone and the blade was booting normally.
The last step was to add old Hast firmware policy to the service profile and check if that brakes it again, but all worked as expected.
So I’m happy that the blade is back but cannot explain how and why this has happened.

Tags: , , , , ,

One Response

  1. CJ says:

    I ran into this exact issue last night when installing 2 new B230 M2 blades into our chassis. The issues noted above are identical. I used a less heavy handed approach and simply reack’d the blade without removing/reapplying the service profile. The difference I saw from the KVM was upon failure I saw the NIC’s listed as shown in your screen cap but did not see any reference to the LSI storage adapter. Upon reack the LSI adapter was plainly visible in the KVM and the service profile applied without issue.

Leave a Reply

IT Blog

Just another blog on Kozeniauskas.com Network