IT Blog

UCS: waiting for flogi

by on Dec.04, 2012, under Cisco, Storage, UCS

Here is one very common error that you can see in  UCS Manager. I’ve observed it in multiple UCS firmware versions and all times it was cosmetic and had no impact.

On the blade you’ll see a major error similar to this:
Description: fc VIF 6 /R A-1095 down, reason: waiting for flogi
Cause: link-down
Code: F0283 

If you go to VIF paths on the blade you’ll see  error ‘waiting for flogi’ on vHBA that has the problem.

Now as I mentioned already this is most likely cosmetic issue. So first you need to verify that this is really the case.

  1. First get the WWPN number and WWNN of the vHBA that is having this issue. Also remember which side(A or B) of fabric the HBA is. From VIF Paths window and from error itself we know that it is on side A.
  2. Select the HBA that is having this problem ant look at the properties to get WWNN and WWPN.
  3. Once you have the WWPN and WWNN login in into UCS CLI.
  4. type connect nxos A (replace A with B if the problem HBA is on B side)
  5. type show npv flogi-table
  6. you should see all the fabric logins on side A. Check if you can find Port name that matches WWPN and Node name that matches WWNN like below.
    ——————————————————————————–
    vfc1905 101 0xe40004 20:00:00:25:b5:01:A0:2d 20:00:00:25:b5:01:11:2d fc2/2
  7. If you can find it then it is cosmetic and everything is working as expected. You can ignore it.

If you’re running VMware ESXi you can check storage paths on it and if the paths are present then again the error is cosmetic.

As you can see  here there are 4 active paths on the HBA that has flogi error and therefor the error is cosmetic as without login into the fabric HBA would not be able to pass any traffic.

To get rid of this error you can try to reset the connectivity on the HBA.

This might get the problem fixed but this will also disrupt the traffic that is passing through this HBA, so I would advise to restart the blade to get it cleared.

This cosmetic issue has been documented in multiple Cisco bugs and was supposed to be fixed multiple times but it keep reappearing:
CSCtu30454CSCub40588CSCtz88841

:, , , , , ,

3 Comments for this entry

  • sean macdiarmid

    having a brain freeze, how do you log into the UCS CLI? are you referring to the KVM console on the blade?

  • Trev S

    We see the same type of vif down messages for Ethernet as well. If you’re running ESXi, check the network adapters for the blade and if they are all up, then ignore the error. It still seems to happen even with the latest versions of firmware.

Leave a Reply